OpenRoads Designer CONNECT Edition SDK Help

ProjectPointOnPerpendicular(DPoint3d) Method

Projects a point onto an element perpendicularly. Gets the closest projection.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearPoint ProjectPointOnPerpendicular( DPoint3d point)

Parameters

SettingDescription
  DPoint3d Point to project.

Return Value

LinearPoint Point projected onto the element.

See Also